読者です 読者をやめる 読者になる 読者になる

SargeのRubyを1.8.5にする

Ruby Debian Rails

railsmongrelを立ち上げたい場合、
rubyは1.8.5じゃないと動かないです。
なのでbackporsから持ってくる必要があります。
/etc/apt/sources.listにbackportsを追加

deb http://backports.mithril-linux.org sarge-backports main contrib non-free
deb-src http://backports.mithril-linux.org sarge-backports main contrib non-free

/etc/apt/preferencesにruby関係を追加

Package: ruby1.8
Pin: release a=sarge-backports
Pin-Priority: 900

Package: ruby1.8-dev
Pin: release a=sarge-backports
Pin-Priority: 900

Package: libruby1.8
Pin: release a=sarge-backports
Pin-Priority: 900

Package: irb1.8
Pin: release a=sarge-backports
Pin-Priority: 900

Package: libreadline-ruby1.8
Pin: release a=sarge-backports
Pin-Priority: 900

これで

apt-get update
apt-get upgrade

でいけるはず。