読者です 読者をやめる 読者になる 読者になる

特定のバージョンのRailsのHTMLのAPIマニュアルを作成する

Rails Ruby

やりかた知らないから、vendorにいったん固めて、
rakeで作成します。rdocでどうのこうのやるの面倒なんだもん。

rake rails:freeze:gems VERSION=1.2.3

これで1.2.3のRails一式がvendor/railsに入ります。
そこで、

rake doc:rails

を実行すると、バラバラーっとHTMLマニュアルを作成し始め、
doc/apiの中に一式入ってしまいます。
このディレクトリをどっかに移動して、
APIマニュアルの出来上がり!

template=kilmer rake doc:rails

の方がテンプレートが好み。
マニュアル作成したら、さっさとrailsを消す。

rm -fr vendor/rails

マニュアルは移動しておく

mkdir -p ~/railsapi
mv doc/api ~/railsapi/1.2.3

ブラウザのブックマークに入れておくとよさそうだ。